Author Topic: Weird black lines...  (Read 953 times)

Offline Noctivagante

  • Zombie Food
  • *
  • Posts: 41
    • View Profile
Weird black lines...
« on: December 22, 2015, 06:43:55 PM »
I have this weird black lines when using any tileset.


Offline CIB

  • Contributor
  • Survivor
  • ****
  • Posts: 305
    • View Profile
Re: Weird black lines...
« Reply #1 on: December 22, 2015, 08:16:19 PM »
Try toggling the software rendering option and restarting the program.

Offline Noctivagante

  • Zombie Food
  • *
  • Posts: 41
    • View Profile
Re: Weird black lines...
« Reply #2 on: December 22, 2015, 09:22:40 PM »
When I enable the software rendering, the black lines are thicker.
The same game directory (same game config) on my other pc, doesn't show those lines...

Offline IguanaMan

  • Zombie Food
  • *
  • Posts: 23
    • View Profile
Re: Weird black lines...
« Reply #3 on: December 22, 2015, 09:47:08 PM »
It's due to the terminal width/height settings under graphics in the options menu.

My monitor resolution is 1920x1080 and setting terminal width to 240x68 gives me black lines but 240x67 looks good, so try tweaking those values.

Offline Noctivagante

  • Zombie Food
  • *
  • Posts: 41
    • View Profile
Re: Weird black lines...
« Reply #4 on: December 22, 2015, 09:58:09 PM »
Yes, I've tried differents terminal values and the lines are always there.
Even fullscreen and windowed borderless.
« Last Edit: December 22, 2015, 10:01:35 PM by Noctivagante »

Offline rremyroy

  • NPC
  • **
  • Posts: 140
    • View Profile
Re: Weird black lines...
« Reply #5 on: December 23, 2015, 04:13:18 PM »
I had the same problem when testing with a Windows XP VM. I'm not sure what is causing this but my guess is poor graphic drivers.

This might also be a bug with SDL on Windows XP.

Try updating your graphic drivers. Let us know if you get better results.

Offline Noctivagante

  • Zombie Food
  • *
  • Posts: 41
    • View Profile
Re: Weird black lines...
« Reply #6 on: December 23, 2015, 05:52:17 PM »
Yes, I will try that.
I'm on Windows 7.

EDIT: Well, same thing with latest drivers. Could be some videocard configuration issue?
« Last Edit: December 23, 2015, 07:38:23 PM by Noctivagante »