Author Topic: Не могу запустить на Ubuntu 14.04  (Read 2928 times)

Offline Schmarotzer

  • Zombie Food
  • *
  • Posts: 3
    • View Profile
Не могу запустить на Ubuntu 14.04
« on: March 05, 2016, 01:31:06 PM »
Эти пакеты установлены:
libsdl2-image-2.0-0 (2.0.0+dfsg-3build2)
libsdl2-ttf-2.0-0 (2.0.12+dfsg1-2)
libsdl2-mixer-2.0-0 (2.0.0+dfsg1-3)
liblua5.1-0-dev (5.1.5-5ubuntu0.1)
liblua5.2-dev (5.2.3-1)

Но при запуске:
$ ./cataclysm-tiles
./cataclysm-tiles: error while loading shared libraries: libSDL2_mixer-2.0.so.0: cannot open shared object file: No such file or directory

Все файлы есть в /usr/lib/x86_64-linux-gnu/
Всё это задано в /etc/ld.so.conf

Куда копать? Уже пару часов пытаюсь запустить игру


Offline LazyCat-rus

  • Survivor
  • ***
  • Posts: 281
    • View Profile
Re: Не могу запустить на Ubuntu 14.04
« Reply #1 on: March 07, 2016, 10:31:39 AM »
а ты сам компилировал или скачал уже собраную?

Offline Schmarotzer

  • Zombie Food
  • *
  • Posts: 3
    • View Profile
Re: Не могу запустить на Ubuntu 14.04
« Reply #2 on: March 07, 2016, 11:51:55 AM »
Сперва скачал ставил B. Не пошло. Нашёл сайт где сделали установщик, скачал, установка экспериментального - не идёт SDL_mixer image ttf не находит. Установил вручную. Не идёт.
Скачал git, пробую сборку make - опять ошибки
ncurses не находит:
(click to show/hide)
поставил libncurses5-dev - всё равно выдаёт эту ошибку

Offline LazyCat-rus

  • Survivor
  • ***
  • Posts: 281
    • View Profile
Re: Не могу запустить на Ubuntu 14.04
« Reply #3 on: March 10, 2016, 06:52:39 AM »
попробуй просто через make `make RELEASE=1`

Offline MEXAHOTABOP

  • Zombie Food
  • *
  • Posts: 75
    • View Profile
Re: Не могу запустить на Ubuntu 14.04
« Reply #4 on: March 12, 2016, 08:30:01 PM »
скорее всего ты скачал 32битную сборку и тебе нужны 32битные библиотеки
сделай ldd на бинарь или посмотри архитектуру через file

лучше последуй предложению скомпилировать с sdl
curses тут на редкость тормозной