Author Topic: Android Version  (Read 23391 times)

Offline s20dan

  • Zombie Food
  • *
  • Posts: 4
    • View Profile
Re: Android Version
« Reply #60 on: February 12, 2017, 06:46:47 PM »

You should check options in-game. There's a bug, when spawn modificators droping to the default value after game starts. I've played with 1 in item and zombie spawn modificators very long, until i noticed that crap.
Fixing is pretty easy: go to the save folder, change the values and put a only-reading flag after.

 Actually I think what happened with me was I was just being dumb :)  I had started a new game several times but I forgot to generate a new world so the settings were still the same as before.

Offline a1studmuffin

  • Zombie Food
  • *
  • Posts: 38
    • View Profile
Re: Android Version
« Reply #61 on: February 13, 2017, 09:31:37 AM »
Elirector: Flick up on a shortcut to remove it. If you remove all shortcuts, it will reset the entire shortcut row to defaults for that screen.

StopSignal: Thanks! No donations necessary but appreciate the thought - I shall have a beer in my honour, haha. I make games for a living, so this is just a fun side project while I have the spare time.

Offline frankokoro

  • Zombie Food
  • *
  • Posts: 4
  • Bladed weapons maniac
    • View Profile
Re: Android Version
« Reply #62 on: February 16, 2017, 06:51:03 PM »
FOUND FIX TO PLAY WITH TILES IF YOU GET GARBLED TEXT!

It's pretty simple actually, you only need a file exploring app.
What you're going to do is go to the app's folder (root/sdcard/Android/data/com.MichaelDavies.CataclysmDDA/files/) and move the GTX folder somewhere easy to find later (IE "sdcard" folder). Now, launch the game and go to the options. Enable software rendering and close the game. Move the GTX folder back into the "files" folder and you're ready to go!
The game should properly open now, and you should be able to play with tiles on.
"...For any normal person this would be a trivial task. But you, you are an adventurer. Everything is a federal fucking issue for you."

Offline a1studmuffin

  • Zombie Food
  • *
  • Posts: 38
    • View Profile
Re: Android Version
« Reply #63 on: February 17, 2017, 01:38:50 AM »
Nice one, well done :D You can probably just rename the gfx folder to something else to stop the game from picking it up.

There is a known issue with the software renderer though: if you rotate the screen it will break. I've been looking into this problem along with the garbled text hardware acceleration bug for the last week. It turns out SDL (the graphics library Cata uses) on Android is riddled with weird bugs like these that only show up for certain devices. I've been able to reproduce the issues in their samples, so I don't think it's anything that the Cataclysm code is doing wrong. I've emailed their mailing list and posted on their forums about both issues, but haven't heard anything back yet.

Turns out native Android development is a real pain in the ass! Trying to make something that works on ~20,000 totally unique devices with wildly varying hardware and capabilities is rather challenging. :)

Offline Metalsoul112

  • Zombie Food
  • *
  • Posts: 4
    • View Profile
Re: Android Version
« Reply #64 on: February 17, 2017, 02:24:48 AM »
Love the port and havent had any issues with it until today! Seems the game crashes when I attempt to manually control vehicle turrets ): Using a Moto G4 if that helps! No way im goibg to be able to kill this tank drone without using the turrets on my vehicle..

Offline hatcher

  • Zombie Food
  • *
  • Posts: 27
    • View Profile
Re: Android Version
« Reply #65 on: February 17, 2017, 11:48:36 AM »
In theory, can i update the game by replacing data files? Found couple of shitty bugs, incompatibilities and unbalanced code which has been fixed in later experimentals.
Eg crash after hitting "f" inside of a vehicle with empty hands,  turrets manual control crash, broken minireactor , PK rebalance debug errors etc.
Or tell how you compiled it, pls.

Offline a1studmuffin

  • Zombie Food
  • *
  • Posts: 38
    • View Profile
Re: Android Version
« Reply #66 on: February 18, 2017, 02:05:18 AM »
Thanks for letting me know RE: instability issues in experimental.

I plan on periodically updating the build to latest experimental and putting the source code up on GitHub once the beta test is complete.

That said, yes you can update the data files yourself. Obviously this will only work for fixing data-only bugs, and if you're using the Google Play version of the game and the app updates, on next launch it will refresh the game data (excluding custom soundpacks/tiles/mods and save games), so you'll need to reapply the patches.

Offline a1studmuffin

  • Zombie Food
  • *
  • Posts: 38
    • View Profile
Re: Android Version
« Reply #67 on: February 18, 2017, 04:19:27 AM »
I just rolled out a new version - download links + changelog in the first post of this thread.

Offline jipopotamus

  • Zombie Food
  • *
  • Posts: 4
    • View Profile
Re: Android Version
« Reply #68 on: February 18, 2017, 11:37:29 AM »
This update seems to have fixed that weird red screen bug!

Offline hatcher

  • Zombie Food
  • *
  • Posts: 27
    • View Profile
Re: Android Version
« Reply #69 on: February 18, 2017, 02:53:09 PM »
But my personal (i guess) bug appears again. After updating game doesn't launching. Game even don't see the new configs from first beta release. So i deleted everything, reinstalled and replaced configs with my old config folder. Now gotta change settings again, god damnit.
At least i have some brains and did save my character folder in other directory.
« Last Edit: February 18, 2017, 06:23:28 PM by hatcher »

Offline a1studmuffin

  • Zombie Food
  • *
  • Posts: 38
    • View Profile
Re: Android Version
« Reply #70 on: February 19, 2017, 06:12:35 AM »
RE: red screen bug, great news :D Now If I can fix the other weird SDL bugs we're seeing, we'll be ready to release!

hatcher: Could you explain the steps you took in a a bit more detail to get it running on your device?
When you say you replaced configs, do you mean you copied over the 'config' folder with your old config folder?
I'm puzzled why you needed to uninstall/clear data to get it working again. When the app upgraded from the previous version (before you uninstalled it), did it say "Upgrading game data", or "Installing game data"? (it should have said upgrading, just checking.)
When it upgrades the game data, it shouldn't touch the 'config' or 'save' folders. It will only refresh data under 'data', 'gfx', 'lua', and 'lang', but will ensure any custom-added stuff like mods/soundpacks/tilesets will be preserved... I followed the logic that the desktop CDDA Launcher uses for this. So I'm confused why it wouldn't launch after the app updated, since your old config should have still been working. Did you delete the gfx folder by any chance?

Offline hatcher

  • Zombie Food
  • *
  • Posts: 27
    • View Profile
Re: Android Version
« Reply #71 on: February 19, 2017, 11:04:42 AM »
Ok, i'll try to explain. For some reasons, game doesn't creating any configs while first launch, except for fonts.json. I copied options.json and keybindings.json into the folder and it helped. After updating (it was "update", not "install") game didn't deleted old saves, configs nor mods, but that weird bug appeared again. I guess, game didn't see old configs, although those configs was accepted and successfully changed before. I checked all possibilities of invalid values in them, but found nothing. Didn't touch those configs before update at all, but i copied em, just in case. File and folder permissions are OK.

> Did you delete the gfx folder by any chance?
I dont get it. Gfx is just a tilesets, no? Anyway, i didn't delete folder, but i deleted all tilesets, except for modded mrshock by xotto which im using.

Btw, without json configs logs are just empty. With json's  there's alot of "couldn't parse color" messages and thats it.
Im pretty sure something wrong on my side, but do not know how to find out whats going wrong  without detailed logs.
« Last Edit: February 19, 2017, 11:10:09 AM by hatcher »

Offline a1studmuffin

  • Zombie Food
  • *
  • Posts: 38
    • View Profile
Re: Android Version
« Reply #72 on: February 20, 2017, 01:08:27 AM »
Thanks hatcher, much appreciated! Glad to hear it didn't nuke any of your configs/saves/mods after the upgrade, I was pretty sure that would be the case but good to have it verified.

I believe the config json files (options.json + keybindings.json) are only created after you modify a setting or keybinding and save the changes. They aren't created on the first run, which is the same behaviour as the desktop build. So I think that's why you weren't seeing them.

It sounds like the data upgrade caused your strange crash bug to appear again. It would have copied all the tilesets back again, so perhaps this was causing the crash somehow. Maybe it was crashing on startup because you deleted the other tilesets, or perhaps it was trying to load one of the default tilesets instead, causing your device to run out of memory. If the current tileset is missing, I think it will try and load "gfx/tinytile.png" as the fallback after that. It's difficult to diagnose without having your specific device handy, but glad it's working now for you anyway. Thanks for checking the logs too.

Offline hatcher

  • Zombie Food
  • *
  • Posts: 27
    • View Profile
Re: Android Version
« Reply #73 on: February 20, 2017, 05:01:11 AM »
Thanks hatcher, much appreciated! Glad to hear it didn't nuke any of your configs/saves/mods after the upgrade, I was pretty sure that would be the case but good to have it verified.

I believe the config json files (options.json + keybindings.json) are only created after you modify a setting or keybinding and save the changes. They aren't created on the first run, which is the same behaviour as the desktop build. So I think that's why you weren't seeing them.

It sounds like the data upgrade caused your strange crash bug to appear again. It would have copied all the tilesets back again, so perhaps this was causing the crash somehow. Maybe it was crashing on startup because you deleted the other tilesets, or perhaps it was trying to load one of the default tilesets instead, causing your device to run out of memory. If the current tileset is missing, I think it will try and load "gfx/tinytile.png" as the fallback after that. It's difficult to diagnose without having your specific device handy, but glad it's working now for you anyway. Thanks for checking the logs too.

I'll try mess around with this after next update ;) But not now, i do not want to set everything on place again. It's working – well, don't touch it – that what i think.
Btw, game don't need those configs for launch?? That will explain everything. Maybe one of the default options causing the crash, but after i loading modified config it dissapears. Yeah, that something with i can work next time.
Also, even the modded mrshock by xotto (32x32) do not causing out-of-memory crash on my device with crappy ≈480mb RAM. So, im not sure its truly the reason because first run crashing.


Protip: changing the font height from 16 to 14 in the fonts.json is giving lot of space for logs/minimap/enemy in sight list. Without drawbacks. Very helpful on devices with ≤5 inches. I expanded logs from 14 to 18 lines, and now i can freackin drive and see latest logs and the minimap at the same time.

Offline Taerzik

  • Zombie Food
  • *
  • Posts: 8
    • View Profile
    • I'm fixing the world. Would you like to help?
Re: Android Version
« Reply #74 on: February 25, 2017, 05:59:35 PM »
A1,

Thanks for doing this for all of us!

I've been having trouble starting the app after the process where the files are downloaded.
Here's what has happened so far:

I first tried to run the app on my phone (5.?). Installation went smoothly but it wouldn't go past the big Z splash-screen.
Then I tried installing on my tablet (6.1), same results.
After the tablet run failed I went back to the phone and dug around a bit until I found the options file.
I think I may have also moved the app to the SD card (via the app manager, not manually.)
I didn't change anything on the phone's files but the next time I tried to run the app it ended up launching and has successfully launched since then.

Unfortunately I haven't been able to locate the same file on the tablet, yet. I did find the com.yourname.cdda, etc. files however. I've made no changes thus far.
The tablet remains stuck at the Z screen.

Do you have any thoughts on what may have caused the phone installation to finally work and what I might need to do to get the tablet working?

Thanks!
Taerzik
« Last Edit: February 25, 2017, 08:08:18 PM by Taerzik »
Ask me about:
Machine Intelligence
Robotics
3D Printing
Threat Analysis & Preparation