Author Topic: Technical Problems, Bug Reporting, and Standing Errors  (Read 4282 times)

Offline GlyphGryph

  • Administrator
  • Survivor
  • *****
  • Posts: 1488
  • Kreaaaaa
    • View Profile
Technical Problems, Bug Reporting, and Standing Errors
« on: December 15, 2014, 12:30:54 AM »
This is a thread to keep track of serious problems with the technical side of the wiki.

Offline GlyphGryph

  • Administrator
  • Survivor
  • *****
  • Posts: 1488
  • Kreaaaaa
    • View Profile
Re: Technical Problems, Bug Reporting, and Standing Errors
« Reply #1 on: December 15, 2014, 12:31:53 AM »
I got this PM:
I've been working on updating the wiki lately, but have run into some problems with 500 Internal Server Errors. Here is what they say:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@wiki.cataclysmdda.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


The problem comes and goes, but just now it was so bad that I couldn't reliably access any pages even after multiple attempts. I mentioned this on the wiki thread after getting an above maximum user error which I hadn't got before. Zireael mentioned that he has had the same problems as me, but KA101 said he didn't have them. I don't know if you can do anything, but KA101 said you were the person to contact.

Offline KA101

  • Administrator
  • Survivor
  • *****
  • Posts: 6858
    • View Profile
Re: Technical Problems, Bug Reporting, and Standing Errors
« Reply #2 on: December 15, 2014, 12:33:23 AM »
Indeed.  No idea what to do re a 500 ISE, as you own the server.

Offline JayJayForce

  • Wiki Contributor
  • Zombie Food
  • ****
  • Posts: 19
    • View Profile
Re: Technical Problems, Bug Reporting, and Standing Errors
« Reply #3 on: December 16, 2014, 01:20:13 PM »
Some additional info:

The wiki seems to work fairly well when I first start and seems to get more unreliable as I make changes, eventually ending with the wiki being unreachable for a while. I just leave it alone for a few hours and it will start working again. I no longer open or save more than one page at a time as I think that makes the problem worse and can get a 500 fairly quickly. I haven't gone around just looking through the wiki, so I can't say how often it happens to regular users, but I Zireael did say he had them.

I'll admit I don't have the best internet here in Africa, but everything else works great, so I really don't think it is my connection causing the problem.

I'll report here if anything further happens.

Offline KA101

  • Administrator
  • Survivor
  • *****
  • Posts: 6858
    • View Profile
Re: Technical Problems, Bug Reporting, and Standing Errors
« Reply #4 on: December 21, 2014, 05:56:40 PM »
Just had a can't contact server error: too many connections.  Worth noting because the isup check still came back OK (and the error persisted) so the typical advice to check downforeveryoneorjustme doesn't work.

~1 PM, US Eastern, 21 Dec 2014.

Offline KA101

  • Administrator
  • Survivor
  • *****
  • Posts: 6858
    • View Profile
Re: Technical Problems, Bug Reporting, and Standing Errors
« Reply #5 on: January 01, 2015, 08:51:47 PM »
Wiki's down until further notice: I botched an upload.

Further notice given: wiki's working again.  go team backup copies!
« Last Edit: January 01, 2015, 10:12:29 PM by KA101 »

Offline TheFlame52

  • Survivor
  • ***
  • Posts: 2184
  • Forumite Summoner
    • View Profile
Re: Technical Problems, Bug Reporting, and Standing Errors
« Reply #6 on: January 02, 2015, 05:42:54 PM »
thank god for backups
Quote from: Jarlaxle
All hail our new Over(powered) Lord TheFlame52
Quote from: Arek_PL
THEY CAN DAMAGE FLAME! WE ARE DOOMED!
Quote from: Jakers
Oh Marloss Man, you and your unstoppable rampages throughout the world.

Offline KA101

  • Administrator
  • Survivor
  • *****
  • Posts: 6858
    • View Profile
Re: Technical Problems, Bug Reporting, and Standing Errors
« Reply #7 on: January 03, 2015, 01:01:16 AM »
thank god for backups

Thank Wikimedia and Git for backups.  ;-)

Offline JayJayForce

  • Wiki Contributor
  • Zombie Food
  • ****
  • Posts: 19
    • View Profile
Re: Technical Problems, Bug Reporting, and Standing Errors
« Reply #8 on: February 08, 2015, 05:12:56 PM »
I just like to say that the wiki seems FAR more stable lately. I only got one 500 error today while working on large pages with an internet that has been acting up a bit and none for a long time before that so major improvement on my side. I'm not exactly sure why or how, but I think it was fixed with all the page trimming that was done.

Offline Endovior

  • NPC
  • **
  • Posts: 164
    • View Profile
Re: Technical Problems, Bug Reporting, and Standing Errors
« Reply #9 on: November 15, 2015, 04:53:44 AM »
The wiki is totally borked, for me; the following text is superimposed over the screen, and no wiki content loads (aside from the following error log, only the logo and some generic wiki stuff is present, on any page). I get the same thing in both FF and Chrome. Error dump follows:


Warning: preg_match(): Compilation failed: group name must start with a non-digit at offset 8 in /home/cataclysmdda/wiki.cataclysmdda.com/includes/MagicWord.php on line 872

Warning: preg_match(): Compilation failed: group name must start with a non-digit at offset 8 in /home/cataclysmdda/wiki.cataclysmdda.com/includes/MagicWord.php on line 872

Warning: preg_match(): Compilation failed: group name must start with a non-digit at offset 8 in /home/cataclysmdda/wiki.cataclysmdda.com/includes/MagicWord.php on line 872

Warning: preg_match(): Compilation failed: group name must start with a non-digit at offset 8 in /home/cataclysmdda/wiki.cataclysmdda.com/includes/MagicWord.php on line 872

Warning: preg_match_all(): Compilation failed: group name must start with a non-digit at offset 4 in /home/cataclysmdda/wiki.cataclysmdda.com/includes/MagicWord.php on line 846

Warning: Invalid argument supplied for foreach() in /home/cataclysmdda/wiki.cataclysmdda.com/includes/MagicWord.php on line 847

Warning: preg_replace(): Compilation failed: group name must start with a non-digit at offset 4 in /home/cataclysmdda/wiki.cataclysmdda.com/includes/MagicWord.php on line 851

Warning: preg_match_all(): Compilation failed: group name must start with a non-digit at offset 4 in /home/cataclysmdda/wiki.cataclysmdda.com/includes/MagicWord.php on line 846

Warning: Invalid argument supplied for foreach() in /home/cataclysmdda/wiki.cataclysmdda.com/includes/MagicWord.php on line 847

Warning: preg_replace(): Compilation failed: group name must start with a non-digit at offset 4 in /home/cataclysmdda/wiki.cataclysmdda.com/includes/MagicWord.php on line 851

Warning: preg_match(): Compilation failed: group name must start with a non-digit at offset 8 in /home/cataclysmdda/wiki.cataclysmdda.com/includes/MagicWord.php on line 872

Warning: preg_match(): Compilation failed: group name must start with a non-digit at offset 8 in /home/cataclysmdda/wiki.cataclysmdda.com/includes/MagicWord.php on line 872

Warning: preg_match(): Compilation failed: group name must start with a non-digit at offset 8 in /home/cataclysmdda/wiki.cataclysmdda.com/includes/MagicWord.php on line 872

Offline Beanzy

  • Zombie Food
  • *
  • Posts: 24
    • View Profile
Re: Technical Problems, Bug Reporting, and Standing Errors
« Reply #10 on: November 16, 2015, 11:20:20 PM »
The wiki is totally borked, for me; the following text is superimposed over the screen, and no wiki content loads (aside from the following error log, only the logo and some generic wiki stuff is present, on any page). I get the same thing in both FF and Chrome. Error dump follows:....


Same thing for me, it seems like there's a problem with the wiki.

Offline Zireael

  • Survivor
  • ***
  • Posts: 1973
    • View Profile
Re: Technical Problems, Bug Reporting, and Standing Errors
« Reply #11 on: November 17, 2015, 08:09:12 AM »
I'm having the same issue.

Offline Toybasher

  • Zombie Food
  • *
  • Posts: 13
    • View Profile
Re: Technical Problems, Bug Reporting, and Standing Errors
« Reply #12 on: November 20, 2015, 12:01:06 PM »
Same. Wiki is completely broken and it's been broken for some time. (Several days.) Can someone contact the staff?

Offline Endovior

  • NPC
  • **
  • Posts: 164
    • View Profile
Re: Technical Problems, Bug Reporting, and Standing Errors
« Reply #13 on: November 21, 2015, 06:14:10 PM »
I sent Kevin a PM about it a couple days ago, haven't heard back yet.

Offline Toybasher

  • Zombie Food
  • *
  • Posts: 13
    • View Profile
Re: Technical Problems, Bug Reporting, and Standing Errors
« Reply #14 on: November 27, 2015, 01:59:02 PM »
Wiki is still dead. Although I'm now getting a different error.

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@wiki.cataclysmdda.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request


Think it's gotten worse because at least before the wiki would still "load". Now it doesn't even make it to the main page anymore.